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 3.  Introduction to Model Building in ShowFlow

Models are built in ShowFlow using a simple two step process.  First, elements (resources such as machines, people, buffers,
conveyors, fork lift trucks, etc.) are placed on the screen as if the user was laying out a floor plan or a flow chart.  The second and final
step is to assign logic to the elements on the screen.

and the following screen will appear.

If is does not, navigate to the Models directory

Here is a short description of some the models in the demo system:

agv.sim -  is a 2D model of an Automatically Guided Vehicle system
bpr.sim -  is a 2D model of a claim processing centre
carrier.sim -  is a 2D model of an assembly line
factor3d.sim -  is a 3D model of an automated factory
operator.sim -  is a 2D model showing multi skilled operators
picklist.sim -  is a 3D model of pickers in a warehouse
reorder.sim -  is a 2D inventory management model
sorter.sim -  is a 3D model of a sortation conveyor
thrghput.sim -  is a 2D model showing the measurement of throughput time
whs_2d.sim -  is a 2D model of a very large warehouse
whs_3d.sim -  is a 3D wire-frame model of an automated warehouse

Double click on the model you wish to see and it will appear on the screen.  To run the model, click

BUILDING A SIMULATION MODEL IN ShowFlow
 1.  Starting the ShowFlow Demonstration Program

ShowFlow will run under Windows 95/98/Me/2000.  To start the program, assuming you have already installed the download, or
installed from a CD-ROM, select Start|Programs|ShowFlow.  The demonstration program is identical to the full version, except that
work cannot be saved in the demonstration version.

 2.  Reviewing Sample Models
The evaluation program includes several sample models from various industries.  To access the models select



2 

 4.  Building a First Model

The following instructions describe a simple manufacturing model with one product type.  The purpose of the model is to analyse
the waiting time of products in the line given a set of machine process times, capacities, and routing conditions.

Once the model is in place, click                        and arcs will appear connecting the elements of your model.  Products will follow
these arcs in a clockwise direction.  ShowFlow’s routing default is sequential, that is element 1 will send to element 2, element 2 will
send to element 3, etc.

To break a routing, click on the element where products are going and drag to the element from where the products came.  In our
model, place your mouse on element 5 and drag back to element 4 and you will see a red line appear.  When you release the mouse
button at element 4, the routing arc from element 4 to element 5 will disappear.  Now break the routing arc from element 4 to
element 3.

To create a new routing, click on the element where products will leave and drag the arc to the element where the products will go.
In our model, click and drag from element 2 to element 4, and again from element 2 to element 5 (the arc from element 2 to 3 already
exists).  Finish the routing by clicking element 3 to element 6 and from element 4 to element 6.  Later we will explain another way
to define the routing of products in the model should you need to include decision logic in your routing.  When your routing is
complete it will look like the model on the next page.

 STEP ONE: MODEL - LAYOUT

From the main menu, select File>New.  Then choose Model>Layout.  The ShowFlow primary elements will appear at the top left
portion of your screen.  Create the elements of the model by first selecting the element type by clicking on one of the bold lettered
buttons at the top of your screen.  Click and place the elements on your screen as shown below.  Element 1 is an In/Out, element 2
is a Buffer, element 3, 4, and 5 are Machines, element 6 is a Buffer, and element 7 is an In/Out.  The small “hot boxes” found in the
top left and bottom right corner of each element allow you to move and size the element you are working on with your mouse.
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You have just completed the first step to model building in ShowFlow.  To move to the second step in model building, exit the Model-
Layout mode by clicking on

 STEP TWO: MODEL-ELEMENTS

To define the parameters of an element, select Model>Elements from the main menu and Model-Elements window will appear.  On
the left-side of the screen is a window with a view of the element on which you are working (it’s the one under the crosshairs).  On
the right side of the window are the data input fields.

Let’s begin by giving a quick description of an In/Out.  An In/Out is a source or sink for products.  It brings products into the model
and takes them out - hence the “creative” name.  Products are the entities that will flow from element to element in the model.

In the data input field, under Job-Parameters, let’s assume that products arrive randomly every 8 seconds.  To do this enter “8” in the
Time field and change the distribution from constant (ShowFlow’s default) to Negative Exponential (“Neg.Exp”).  When complete,
the Time field should look like the screen on the next page:
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Move now to element 2, the first buffer in the model.  The quickest way to move from element to element while in Model-Element
window is to click on the “N” (for next element) or “P” (for previous element).

When you are at element 2, change the capacity from the default of “10” products to “100”.

Next, go to each of the machine elements (elements 3, 4, & 5) and assign job times (process times) to each of them.  In this model,
we will enter the process time of each machine as a constant 24 seconds.
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When you have finished entering the Job times to the three machines, click the OK button at the bottom left of Model-Elements
window.

 RUNNING THE MODEL

Before running the model, check to see if the History is turned on.  Select Settings>Simulate and make sure the Store History button
is checked as indicated below then click the OK button.

To run the model, click                       When the model begins to run, a Simulation Control window will appear at the top right corner
of the screen.

This screen allows you to control the speed of the model (the higher the number the faster the animation) and the type of animation.
Changes can be made to the speed and animation of the model at any time.  While the model is running, increase your speed to “9”
and change the animation from Full to Statistics.  In this 2D animation mode, The model will automatically give utilisation percent-
ages of the three machines and queue sizes at the buffers.

The model will run for 8 hours.  You can see the clock at the bottom righthand corner of the screen run in condensed time.  It will
take this model 10-30 seconds to run 8 hours of “history” depending on how fast your PC is.
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The histogram shows the average waiting time per product in the model’s first buffer (element 2).  The histogram also shows the
percentage of elements that were processed within 60 seconds (the red percentage at the top of the histogram).

 GENERATING GRAPHS AND REPORTS IN ShowFlow

When the model has completed its 8 hour run, results can be generated by clicking on                          The Results -Element Graphs
window will appear.  Select Buff_2 in the Element dialog, then complete the Results - Element Graphs screen as shown below.  Note
the entries at Graph type, Averages and make sure you check to show percentage less than 60, then click on View.
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What did your results show?  Did you expect your manufacturing line to be better balanced than it was?  Were you surprised that the
only non-constant event in the model (the arrival of products) created such high waiting times?  What would happen to the model
if the process time of each machine was improved by 10%?  How much will a 10% improvement in process time decrease the
waiting time of products in buffer 2?  Go back to the Element - Model window and change the Job Time from 24 seconds constant
to 21.6 seconds constant (24 seconds - 10%) in each machine (elements 3, 4, & 5) and click on OK.  Run the model again and view
the graph.  How much did the decrease in process times at the machines improve waiting time of the products being processed?

Try some other “What-if” scenarios with the model.  Here are some suggestions

1 - What if - the machines did not process products at a constant rate but rather processed each product within a range of 22-26
seconds per product?  How will that affect the waiting time of products in the system?  To make these changes set up your process
time as shown below, run the model and view the results.

 CHANGING THE MODEL AND PRESENTING ALTERNATIVE “WHAT-IF” QUESTIONS
 TO THE MODEL
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The Mtbf field stands for Mean Time Between Failure and Mttr stands for Mean Time To Repair.  Here is where we input how
frequently the machine breaks down and the time required to repair the machine.  The inputs above shows the machine breaks down
on average every 14400 seconds (4 hours) and requires 600-1200 seconds (10-12 minutes) to repair.  Notice that all of the times we
have entered into our model and have viewed in our graphs have been in seconds.  This is the default time unit in ShowFlow, but time
units in ShowFlow can be defined by the user.  Time units can be seconds, minutes, hours, days, or any other time unit established
by the program’s user.  However, the discussion on changing the default time of this model will have to wait until you attend a
ShowFlow training course.  For now, just remember that all time units shown in your model will be in seconds.

3 - What if - element 6 (our second buffer) were to become an inspection station that processed 5 products every 4 seconds (give or
take 1 second)?  In addition, what if 10% of our products had to be returned from the inspection station to Buffer 2 and reprocessed
through the model for rework?  How would this scenario impact waiting time?  To set these logic parameters, go to the Model-
Elements screen for Buffer 6 and enter “5” under Capacity.  Earlier, we said we would discuss other ways of routing products in the
model.  Let’s discuss that here.

At the bottom of the Model-Element screen are the Stage Parameter fields.  These fields were automatically completed when the
routing was created earlier in the model by clicking and dragging the mouse from element to element.  However, in ShowFlow routing
parameters may also be assigned by entering the number of the element where products are to go in the Send to field.  While in the
Model-Elements field of element 6, you will notice that the Send To field shows the number “7”.

Back to our model, at element 6 change the capacity from 10 to 5.  Change the Job to 4 seconds with a Normal distribution and a
standard deviation of 1 (see Job Parameters in the Model-Elements screen below).  This job time will tell the model that 5 products
will be inspected on average every four seconds, but that sometimes it takes only three seconds and at other times it takes 5 seconds.
At the Send To field we will enter a logic statement to return 10% of the inspected products to element 2 and back through the system
for rework.  To do this, type bernoulli[90,7,2] in the Send To field of the Stage Parameters of element 6.  This statement tells the model
to send 90% of the products to element 7 and return the balance (10%) to element 2.  The Element-Model Field should look like the
one on the next page when you have finished entering these logic parameters at element 6.

2 - What if - one or all of the machines had a history of breaking down?  To model this, go into the Element-Model window and
complete the screen as shown below:
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Several other what if scenarios could be analysed in this simple model.  What if workers were assigned to operate the machines in
the model?  What if we had three different products coming through the line and each product type was assigned to go to a specific
machine?  What if the marketing department forecasted a 25% increase in orders for the next quarter - can the current line handle the
increased throughput?  If not, what would be the most cost effective method for meeting the expected increase in production -
additional shifts, new and faster machines, or some combination of the two?  If we have determined that new machines are needed,
what is the optimal number of new machines required to meet the increased demand if each new machine costs £1,250,000 and an
additional £165,000 to operate per year?  If the net revenue is £1.25 per produced product, when can a return on investment be
expected on the new machines?  What will happen to the system if, thanks to the new machine(s), the rework rate decreases from
10% to 6.5%, the process time is decreased from 22-26 seconds per product to 17.5-19.25 seconds, and the expected breakdown
decreases from 10-20 minutes per day to 30-60 minutes per week?
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 CHANGING ANIMATION STYLE IN ShowFlow

To convert a 2D model to 3D is very simple in ShowFlow.  Select View>Animation, choose Full for animation level, and set the
desired speed level.  Speeds between 7-9 look best in 3D.  Also, change the Refresh Rate from 100 to 1.  This will make the movement
of products look smoother as they flow from element to element.  Change View Mode to 3D and choose 3D solid icons for your
elements and products, then click OK.  Now run your model and the elements will automatically change to 3D (see View-Animation
screen below).

To change the 3D view angle of the model, select View>Viewpoint Manipulator.  By clicking on the various icons you can move the
model, rotate it up, down and around, as well as increase and decrease its size.  A wire frame of the model will remain on the screen
so that the angle and the position of the model can always be seen.

The 3D icons selected were chosen automatically by ShowFlow.  If you want to replace the 3D icons in the mode select
View>Animation>Elements and scroll through the elements and select replacement 3D icons.

How did your failure rates and/or rework of your products affect the waiting time of the products?  After looking at your histogram,
take a look at a utilisation pie of the machine(s).  To do this click on                   and complete the fields as shown:
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Now run the model in 3D

As you may have seen, all ShowFlow models are built in 2D.  After the model has been built the model can be converted into 3D.
Animation serves three primary functions.  First, it makes model building easier because the user can see what he or she is doing and
which element he or she is working.

Second, ShowFlow’s animation acts as a debugging tool.  For example, if a modeler expected element 54 to send a batch of 10 products
to element 125 when element 125 is operating at 35% of capacity and this activity does not occur on the screen, the modeller will
know that something in the logic must be corrected.  This is because the animation and simulation are fully integrated in ShowFlow.
In other words, what is on screen is what has been modelled - and conversely - what has been modelled is what is on the screen.  This
is a very important and unique feature in ShowFlow.  Many simulation products’ animation are not integrated with the simulations
logic and the modeller cannot trust what the animation is showing.

The third function of animation is presentation.  Animation is a useful tool for communicating ideas and results.  ShowFlow provides
several levels of 2D animation and is the only PC based simulation product to provide true 3D animation for less than £10,000!

 5.  Building Other Models in ShowFlow

If this model was not challenging enough for you, go to the ShowFlow Tutorial and you will find three additional models.  The tutorial
can be found in ShowFlow’s Help file.
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 6.  Other ShowFlow Features

We believe ShowFlow offers the best value for money of any simulation package.  The reason we say this is because of all the features
included in the software.  Some notable features found in ShowFlow include several levels of both 2D and 3D animation, dynamic data
exchange links to Excel spreadsheets, the ability to easily import CAD drawings, a module to design experiments, costing features to
analyse the cost benefits of scenarios modelled, an advanced statistics module to curve fit raw data, and generators for custom reports
and graphs.  All of these make ShowFlow fantastic value for money, and feature competitive with packages costing more than fifty
times the price!  However, according to ShowFlow users the primary characteristic that sets it apart from other simulation programs
is that ShowFlow IS THE EASIEST SIMULATION PACKAGE TO LEARN AND USE.

 7.  Recommended System Requirements

PC with Windows 95/98/Me/2000, (Windows NT4 with a very minor restriction)
60 MHz Pentium processor or better
32 Mb RAM
20 Mb Available Hard Disk Space
Super VGA Monitor 800x600 (1024x768 recommended)
Keyboard
Two Button Mouse
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